Can't launch client: Can't load library gluegen_rt.dll

The worst monsters in the Hearthlands warp the fabric of space and time...

Can't launch client: Can't load library gluegen_rt.dll

Postby partinez » Mon Mar 28, 2022 7:10 pm

Hi. Asking here after trying to fix this for 3 hours now. I can't get the client (Official or Ender's) to launch. I start the launcher, I see it do some stuff and then they show this error:

Code: Select all
java.lang.UnsatisfiedLinkError: Can't load library: E:\HavenAndHearth\natives\windows-amd64\\gluegen_rt.dll
   at java.lang.ClassLoader.loadLibrary(Unknown Source)
   at java.lang.Runtime.load0(Unknown Source)
   at java.lang.System.load(Unknown Source)
   at com.jogamp.common.jvm.JNILibLoaderBase.loadLibraryInternal(JNILibLoaderBase.java:625)
   at com.jogamp.common.jvm.JNILibLoaderBase.access$000(JNILibLoaderBase.java:64)
   at com.jogamp.common.jvm.JNILibLoaderBase$DefaultAction.loadLibrary(JNILibLoaderBase.java:107)
   at com.jogamp.common.jvm.JNILibLoaderBase.loadLibrary(JNILibLoaderBase.java:488)
   at com.jogamp.common.os.DynamicLibraryBundle$GlueJNILibLoader.loadLibrary(DynamicLibraryBundle.java:427)
   at com.jogamp.common.os.Platform$1.run(Platform.java:321)
   at java.security.AccessController.doPrivileged(Native Method)
   at com.jogamp.common.os.Platform.<clinit>(Platform.java:290)
   at com.jogamp.opengl.GLProfile.<clinit>(GLProfile.java:154)
   at haven.JOGLPanel.mkcaps(JOGLPanel.java:74)
   at haven.JOGLPanel.<init>(JOGLPanel.java:94)
   at haven.MainFrame.<init>(MainFrame.java:172)
   at haven.MainFrame.main2(MainFrame.java:386)
   at haven.MainFrame.lambda$main$0(MainFrame.java:422)
   at java.lang.Thread.run(Unknown Source)



The directory is empty except for the launcher.

I've searched and researched the forums (and Google) and can't find the solution. My computer:
GPU: GeForce GTX 1060 + Integrated (I've disabled it in device manager)
GPU driver: 512.15 (updated today)
Windows 10 64bit

I've tried:
* Uninstalling Java, installing Java8 for 64 bit
* Uninstalling Java, installing other open source alternatives.
* Downloading the jogl and gluegen_rt files and putting it in different relative directories. I've had some minor apparent improvements but they end up in some other errors so I assume I don't have the correct versions.
* restarting many times

From what I understand, the launcher should download the required dependencies. I tried some version of the Amber client that I found and I actually got it to launch, but half of the background image is missing and the client is no longer supported.

Any ideas on things to try?
partinez
 
Posts: 39
Joined: Tue Aug 17, 2010 12:39 am

Return to Bugs

Who is online

Users browsing this forum: Shuhay42069 and 1 guest