TP Map Tool v4.0.27

Forum for alternative clients, mods & discussions on the same.

Re: TP Map Tool v4.0.27

Postby njkc07 » Sun May 05, 2019 6:49 pm

Need some help here. Have used both instructions above and on OP. The most I can get to show is a 5x4 map are of tiles, the rest black. All folders are pointing to where they should and I have certainly ventured out further than what is being shown. Anyone have an idea what I might be doing wrong?
Posts: 4
Joined: Wed Mar 27, 2019 1:24 am

Re: TP Map Tool v4.0.27

Postby Lithorn5 » Mon Jul 01, 2019 7:23 pm

I never did get this to work, even after setting the directories and after following the instructions. Its always just stayed a black square. I use Ender's Client, and have tried several suggestions mentioned here. Renaming a session to 5 did nothing after putting it in the layers folder, nor did changing the maptile numbers to be 0.0 or the paths. Ah well
Posts: 17
Joined: Wed Jul 17, 2013 3:54 am

Re: TP Map Tool v4.0.27

Postby Lithorn5 » Mon Jul 01, 2019 7:44 pm

Telakh wrote:Hi uncleseano.
I am sorry for poor description as I am constantly short on time. I'm wokring on a better readme and will post it in about a day.

I have uploaded v.4.0.28 that should be more user-friendly on first launch. Settings.xml file is missing in the distributive now and will be generated during the fist run.

Please note that in order the map tool to work you have to make sure that:
- you have downloaded the entire TP Map Tool folder.
- you have .net Framework 4.5 or higher installed.
- your game client does save the map sessions (this option is disabled by default now).
- TP Map Tool has enough permissions to create files and folders at it's own folder.

During the first startup the program will do the following (if Settings.xml file is missing):
- Generate settings.xml file.
- Set the default map archive path to the \<TP Map Tool path>\Map\ and create the specified folder. (lets call it <MapArhive> further)
- Set the map layers path to the \<MapArhive>\Layers\ folder and create a first layer folder if it is missing: \<MapArhive>\Layers\1. Surface\

You should be able to see the "1. Surface" layer upon startup in the layers. The map will be blank black as there are no tiles yet.
You have to open options and set the map sessions path to the folder that contains client map sessions. Example: C:\Games\Ender\Map\ You may also want to change the map archive path to a different folder. If you want to create more layers (for caves), you will have to do it manually at this point by creating more folders at \<MapArhive>\Layers\
If you start a Merge from the menu with an empty archive, the MapTool will copy the first available session from the sessions path and will start making map from this session or you may copy one or a few tiles from a session of your choice to the \<MapArhive>\Layers\1. Surface\1\ folder and your map will be merged from this point.

Please let me know if you have any questions or face any errors.

DeadHazard , I will make it possible in a couple of days. Cheers.

I tried this, black screen =\ It dosen't see the Ender Map folder sessions, it also dosen't see any tiles when I paste them in. I've tried Layer 1, and 5, I've also tried a folder named "5" in the archive as mentioned in the readme. Nothing
second.jpg (4.31 KiB) Viewed 3525 times
first.jpg (7.56 KiB) Viewed 3525 times
options.jpg (51.32 KiB) Viewed 3525 times
Posts: 17
Joined: Wed Jul 17, 2013 3:54 am

Re: TP Map Tool v4.0.27

Postby Lithorn5 » Mon Jul 01, 2019 7:56 pm

last image to show I have atleast 1 session (Feel free to discord me if you think you can help, Lithorn#3961

Things to note, Ender map files will never "match" as they are all different in size. If your program is set to ignore unmatched tiles, it will ignore everything ender has in sessions I would think.
fourth.jpg (15.27 KiB) Viewed 3524 times
third.jpg (17.29 KiB) Viewed 3524 times
Posts: 17
Joined: Wed Jul 17, 2013 3:54 am

Re: TP Map Tool v4.0.27

Postby Heffernan » Sat Nov 30, 2019 10:26 am

uh question does the Source Exists somewhere or can u contact the dev by mail or anything?

im trying to use the map tool on the original game Salem and ot doesnt work

TP Map Tool v3.3.4 TEST =

TP Map Tool v4.0.28 has a new Structure and you can move the tiles in there to make it work, but

1) manual merging is missing
2) automerging doesnt work with Salem
Posts: 17
Joined: Sun Mar 25, 2012 3:30 pm

Re: TP Map Tool v4.0.27

Postby kmarad » Wed Jan 15, 2020 5:18 pm


Your tool looks great for windowsians, though I'm not one of them.
So I'm trying to code my own whole map builder.

I've been comparing ids from IDS.txt to build the map, but I have some issues. Please see :

Could you please give me a hint about how ids work ?
Posts: 132
Joined: Mon Jan 06, 2020 7:46 pm

Re: TP Map Tool v4.0.27

Postby virtualpolecat » Fri Apr 17, 2020 3:05 am

I just tried to use this but it keeps showing up my winter tiles even though I deleted those so the new spring ones would fill in. Any help is appreciated.
W12: Charlie IV III II I
User avatar
Posts: 8
Joined: Sat Apr 11, 2020 12:51 am
Location: Houston, Texas

Re: TP Map Tool v4.0.27

Postby ijash » Wed Jun 07, 2023 4:20 pm

is this still working? I tried it, following the tutorial, but not working.
Posts: 1
Joined: Thu Oct 13, 2011 9:30 am

Re: TP Map Tool v4.0.27

Postby Vladichka » Tue Jul 25, 2023 3:09 am

Am I screwed if I use Ender client? I can't find map cache in any form anywhere, it doesn't seem it stores raw map tiles. Am I missing something?
Posts: 16
Joined: Tue Jul 18, 2023 8:26 pm


Return to The Wizards' Tower

Who is online

Users browsing this forum: No registered users and 1 guest